Kategória: PHP5

Magento 1 PHP5.6 és Magento 2 PHP7.1 egy Apache

A fejlesztéseim korlátjába ütköztem amikor is a Magento 1-es porjektekhez még PHP5.6 kell de a Magento 2 fejlesztésekhez már PHP 7.1 kellene. Ubuntu 16 alatt viszonylag könnyű megoldani a problémát. Használhatnék Docker-t is, de másnál nem kell felhúzni a fejlesztői környzetet. Apache webszerverrel dolgozom, mert Magento fejlesztéseken kívül mással is dolgozom. A cél az, hogy egyszerű konfigurációval lehessen egymás mellett PHP5.6-os és PHP7.1-es projekteket futtatni.

Azt, hogy melyik oldal melyik PHP-t használja Vhostban fogjuk beállítani. A megoldához pedig PHP5.6 és PHP7.1-et telepítünk FPM módban:
sudo su
add-apt-repository ppa:ondrej/php
apt-get update
apt-get install libapache2-mod-fastcgi php5.6-fpm php5.6 php5.6-dev php5.6-mcrypt php5.6-mbstring php5.6-mysql php5.6-zip php5.6-gd php5.6-xml php7.1-fpm libapache2-mod-fastcgi php7.1-fpm php7.1 php7.1-dev php7.1-mbstring php7.1-mysql php7.1-zip php7.1-gd php7.1-xml php7.1-curl php7.1-intl php7.1-json php7.1-mcrypt

“Magento 1 PHP5.6 és Magento 2 PHP7.1 egy Apache” Tovább olvasása

Reklámok

PHP Symfony 3.1 framework Sonata Admin 3.8 Bundle with PHP 5.6.x

Sajnos nem elég rég óta foglalkozom Symfonyvel ahhoz, hogy elsőre sikerüljön a Symfony 3 és a Sonata Admin Bundle összehozása PHP 5.6 alatt. Mivel úgy igazán nincs leírva sehol sem, legalábbis én nem találtam, többszöri Google-zás után sem, hogy melyik verzió, mivel hozható össze “gyorsan” (A packagist.org-on persze meg lehet találni a megfelelő megoldást ha időd mint a tenger, vagy a rutin meg az évek mondják meg).

Nos sikerült egy olyan megoldást találni, amivel a Sonata Admin behúzható egy 3-as Symfony alá. A FOS userbundle segítségével jó lenne megoldani a felhasználó kezelést, de ha minden igaz ez jelenleg még nem megvalósítható. A célprojektem kivitelezését meg nem húzhatom emiatt tovább, így másik alternatívát kell keresnem, nah de lássuk Symfony 3.1-alatt a Sonata Admin-t:

Ehhez a Symfony 3.1-es változatával kell létrehozni egy projektekt Composer segítségével: “PHP Symfony 3.1 framework Sonata Admin 3.8 Bundle with PHP 5.6.x” Tovább olvasása

Magento 1.9.2.0 és Magento SUPEE-6285 biztonsági frissítés

Megjelent a Magento 1.9.2.0-ás változata, a frissítéssel egy idejüleg kijött egy újabb biztonsági frissítés (SUPEE-6285) is a korábbi Magento verziókhoz. A frissítés előtt telepíteni kell a korábbi SUPEE-5344, SUPEE-5994 biztonsági frissítéseket is. A frissítés a szerverre SSH-n keresztül bejelentkezve lehet elvégezni. Sajnos a frissítések idején több helyen változott a Magento fájlok fejléc komment szövegezése ezért a frissítések nem minden esetben futnak le automatikusan. Ekkor fájlonként és soronként kell elvégezni a frissítést, ami túlságosan időigényes. A frissítéseket a Magento hivatalos oldaláról lehet letölteni: “Magento 1.9.2.0 és Magento SUPEE-6285 biztonsági frissítés” Tovább olvasása